Exploit Notification - Abyssal Siege Modules

by EVE Online Team7:20pm on Friday 3rd December 2021

It has come to our attention that there is a defect which enables Abyssal Siege Modules to bypass the usual Dreadnought-only fitting restriction and be fit to some other ship types. Effectively immediately this is now considered an exploit as ships other than Dreadnoughts are not intended to use Siege Modules of any kind.

A fix for this defect has been prepared and will be deployed next week.

In the meantime if you observe players using a ship other than a Dreadnought with a Siege Module fitted actively engaging in any type of gameplay please get in touch with our customer support by sending in a ticket in the ‘Rules & Policies – Exploits’ category.